2 Replies Latest reply on Jan 8, 2018 10:39 AM by jafoste4

    linux for avnet zynq-mmp 7z100

    avidanda101

      hello all,

      I am using petalinux 2017.1 and willing to boot linux image from sd card.

      I did it well for zcu102 xilinx board and having some problems with booting avnet zynq-mmp.

      I cant fined bsp fits for 2017.1.Is it OK to use another version of bsp with petalinux 2017.1?

      Is it OK to use hdf file that was created with previous version of vivado  or should it must be the same version?

      Thanks ahead.

      Avidan.

        • Hello Avidananda,
          jafoste4

          Hello Avidananda,

          It is not suggested to mix different BSP versions / petalinux versions / hardware design versions. All versions should be the same revision, so if you are using petalinux 2017.1, you should use a BSP generated using 2017.1 and also use a hardware design from the 2017.1 vivado tool set.

          Looking at what we provide for the MMP, we only have up to 2015.2.1 BSP released for the MMP. I will check with our engineering team to determine if we plan to update this BSP any further.

          In the mean time you could always create your own BSP if you still want to use Petalinux 2017.1. Please refer to this link.

          http://zedboard.org/content/how-bsp-files-added-sdk

          --Josh

          • At this time we do not plan
            jafoste4

            At this time we do not plan on updating the BSP's for the MMP. Your best bet is to create your own BSP targeting the Petalinux version you wish to use.

            Regards,

            Josh