2 Replies Latest reply on Jul 12, 2017 4:40 AM by rathseg

    Vivado crashing in Hardware Manager with Zedboard. Windows 10 Pro x64


      Based on a previous post, it was recommended that I upgrade to the latest Vivado edition for my own projects and to only use 2014.2 for the zedboard tutorials on this site.  I tried doing that and have run into a rather severe bug.  In versions 2016.4, 2017.1, and 2017.2, they all crash 100% of the time after opening the hardware manager to download your bitstream to the zedboard (I'm mostly using interested in just using the FPGA logic right now, so I don't often need the SDK atm).  If you move through the menus quickly, you can actually get it to program before Vivado crashes, but it will crash somewhere between 10 seconds and a minute after opening the hardware manager and open the connection options whether it is the "Open Recent" or "Open a new hardware target".  


      But it doesn't just crash, it crashes so ungracefully that it deletes c:\<install base directory>\Vivado\201X.X\bin\vivado.bat which prevents Vivado from begin started again.  So you have to reinstall Vivado to even start the program again.  I tried to be clever and after this happened twice, I saved vivado.bat with the intention of copying it back to its normal location if it got deleted.  But when I did that ( after having to turn off Windows UAC since Vivado is installed into the base C: drive which broke other programs on my computer until I renabled UAC ), I found that at least one more file had been deleted which was vvgl.exe.  At that point I stopped trying to be clever and reinstalled any time it happened.  I've been through probably close to 10 reinstalls now which is how I figured out the range of places where it can crash and have experienced this across multiple recent version of Vivado.


      This does not happen on 2014.2, so I can still make progress and use my board, but 2014.2 is old and has its own set of bugs, though not as bad.  Plus with the facelift that Vivado got starting in 2017.1 I would really like to use the newer versions.  I have not tried with versions in between 2014.2 and 2016.4, so I don't know which version this problem starts to appear.


      I'm starting on this forum since on the official Xilinx forums I have seen several posts be referred to their respective FAE, which I think would be here with AVNet.  Let me know if there things like log files or other information I can provide to help debug this.  From looking at this forum and the Xilinx forums, no one seems to have posted with an issue like this, which is worrying since it might be some specific interaction related to my system with Vivado.  =/


      System Information:

      Windows 10 Pro x64 
      version 1607
      OS Build: 14393.1358
      Intel Core i7-3770K

        • Hello Rathseg,

          Hello Rathseg,

          I can say I have never experienced nor heard of the issue you are experiencing. Unfortunatly my suggestion would be for you to go ask your question over at Xilinx because based off what you described above they have atleast some experience/know about the issue you are facing.



          • Solved

            This was figured out with some help from the Xilinx forums.  It was my Anti-virus software false detecting Xilinx files and quarantining them.  I added exclusions for the base install directory and reinstalled and it works now.