6 Replies Latest reply on Feb 10, 2016 7:33 AM by vhdlrocks

    Cannot get simple app to load on MicroZed using PetaLinux

    vhdlrocks

      Vivado 2015.4
      PetaLinux 2015.4
      Windows 7 running VirtualBox & Ubuntu 14.04
      MicroZed Rev F

      I have followed the guide for the Mini-ITX and the guides provided from Xilinx to build PetaLinux on a MicroZed. I just want to see the UART output "Hello World" but the steps provided don't work for me.

      The supplied SD image works fine.

      Anybody on these forums remember any details that aren't included in the tutorial?

      Thanks in advance.

        • More info
          hockeyman1972

          Hi Jeff, 

          From the title I'm not sure if you have helloWorld in the root file system and it runs but doesn't produce output, or if you can't get it to show at all in the final build.

            1. Are you placing the application code in the correct structure within the PetaLinux project (see example BSPs for 2015.2 on this website for examples - it's the same in 2015.4)?

          2. Have you selected your application for inclusion in the build in the rootfs configuration?

          3. Do you see the application being built during the build process (or check the build_log)?

          4. If helloWorld is present, does it execute and simply produce no output?  This would imply something else is going on, if you are seeing all the output from the boot correctly.

          Ron

            • 1. I run the following
              vhdlrocks

              1. I run the following command to generate my first app
              $ petalinux-create -t apps --template c --name myapp

              2. I have selected to use this app in the config window after running:
              $ petalinux-config -c rootfs

              3. The build log includes "myapp" in the build.

              4. I am able to do generate a BOOT.BIN and image.ub successfully. I do see an error in the build log: [ALL  ] rsync error: error in file IO (code 11) at main.c(674) [Receiver=3.1.0]

              Thanks Ron. Any thoughts?

              • Ron,
                vhdlrocks

                Ron,

                I believe the rsync error is because I don't have tftpboot setup. This wouldn't cause a problem though, right? I don't want to use the Ethernet port for booting. I am trying to use the SD card to bott.

                  • Boots ok?
                    hockeyman1972

                    Jeff,

                      So it sounds like everything builds correctly and you get a boot.bin and image.ub that you can copy to uSD and boot the device.  What happens when you do that?  Any errors in the boot log?  You are able to locate the helloWorld binary ok?  And it runs without error but you see no output?

                    Ron

                      • Ron,
                        vhdlrocks

                        Ron,

                        That is all correct except I cannot talk to my MicroZed to check for my app. I even fixed the tftpboot issue and now have zero errors. When I download the BOOT.bin & image.ub file to the SD card (used FAT32 to format) and plug the card in to the MicroZed nothing happens. I am expecting to see the board boot over the UART and get a basic Linux CLI but I don't get anything.

                        I know it is not my USB/UART connection because I can load the Linux image that came with the MicroZed and access Linux through the UART.

                        I will be honest, I am expecting to get a CLI without provided any code of my own using the PetaLinux build process. Is this the problem? Do I need to write the CLI? I don't know what to expect being new to embedded Linux.

                        Thanks Ron