1 Reply Latest reply on Oct 31, 2012 12:07 PM by timduffy

    ChipScope Tip

    josephsamson

      I used ChipScope for the first time on the Zynq the other day and learned something important: the AXI clock (and I assume the other 3 clocks available from the PS) don't run until the PS is initialized.

      I've been using ChipScope for many years, and I have gotten into the habit of clicking the T! button (manual trigger) when first running ChipScope after a new bitstream build. I've just had too many times where the clock to the ChipScope wasn't routed properly and I got the dreaded 'Waiting for trigger, slow or stopped clock' message.

      So, when I loaded the bitstream and started up ChipScope on my new Zynq design, I clicked T! and saw that it was stuck waiting for the trigger. I was using the AXI clock as the ChipScope clock. After digging into the routing, I came to the conclusion that the problem wasn't there. Later, I wondered if the clock just hadn't started up yet. I ran the Hello World demo, and then all was right with ChipScope. The manual trigger worked.

      ---
      Joe