5 Replies Latest reply on Oct 25, 2018 10:39 PM by jansen0326

    How to setup and use platform cable in VirtualBox image when host is Ubuntu OS

    jansen0326

      Hi,

        My computer OS is Ubuntu 18 when I use VirtualBox to build Ubuntu 16.04 and wish to run SDK and petalinux, how can I use and set up the platform cable in the Virtual machine? I have followed the instruction in  VirtualBox_Installation_Guide_2017_2.pdf to install all tools, but the Platform cable still not work. Because of the Ubuntu could not autodetect the Platform cable likes windows and showing the item in equipment->USB.

        • Hi,
          jafoste4

          Hi,

          Please ask this question over at Xilinx, we typically use the Digilent HS3 cable for our JTAG purposes.

          -Josh

            • Hi Josh, 
              jansen0326

              Hi Josh, 

              Actually, I do the SpeedWay lab and run to Lab1(MiniZed_PetaLinux_Speedway_lab1_2017p4_v2.pdf) Page17, but I can not write into flash. the SDK Console show the message below.
              =========================================================================================

              ****** Xilinx Program Flash

              ****** Program Flash v2017.4 (64-bit)

                **** SW Build 2086221 on Fri Dec 15 20:54:30 MST 2017

                  ** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

               

              Connecting to hw_server @ TCP:127.0.0.1:3121

               

              WARNING: Failed to connect to hw_server at TCP:127.0.0.1:3121

              Attempting to launch hw_server at TCP:127.0.0.1:3121

               

              Connected to hw_server @ TCP:127.0.0.1:3121

               

              ERROR: Unable to detect JTAG cable

              ============================================================================================

              Jansen

            • Hi Jansen,
              jafoste4

              Hi Jansen,

              I am not too familair with the ur ubuntu enviroment. It appears that your ubuntu enviroment is not recognizing your jtag platform cable, when you have enabled it in ubuntu which was done during the virtual machine installation guide your referenced. My suggestion would be to put this post on the Xilinx forum as they are more familiar with the platform cable.

              • Hi JFoster,
                jansen0326

                Hi JFoster,

                  Maybe I write the wrong title, let me explain it.

                  My Host OS is Ubuntu, and I have installed the SDK 2017, I use MiniZed to do the MiniZed_PetaLinux_Speedway Lab. I could do all labs and successfully write the image to QSPI flash. but for easy to move to another platform and keep for further usage, I need to build the VM image, I use VirtualBox to build the Ubuntu 16 OS and install all stuff just follow the MiniZed reference Design document VirtualBox_Installation_Guide_2017_2.zip, all are successful, but when I want to write the image into QSPI flash in Lab1, I encounter this problem.

                I have the VM image you build for training, it also not works, to write the QSPI. but if I move it to the windows OS host, it's work fine, just like you do in the training.

                OK, I want to say is, the windows OS seems could pass the USB device(Xilinx JTAG+Serial[0700]) into VirtualBox, but Ubuntu couldn't. 

                 It's any way to pass the USB device to VB, or the Lab could not write the image when the host is Ubuntu OS.

                Jansen

                • Hi,
                  jansen0326

                  Hi,

                    I temporarily solve this problem, you need to run hw_server in the host PC, when Program Flash Memory in VM SDK, build a new connection and key in the Host IP to replace local programming.

                  This will redirection the programming from local VM to Host PC, this will success to program MiniZed board.

                   

                  Jansen