6 Replies Latest reply on Feb 2, 2019 6:04 AM by voltsandjolts

    Changing Templates does not work

    sclifford

      Why can I not change the templates in CS to load my own logo.    I am using the Letter format yet when I load the form form the location noted in C:\Users\Public\Documents\Altium\CS\Templates it is completely different than the one show in CS.  Second when i load the form it has a black square in the center as well as when I load a logo CS lock up completely!

      Here is the Version that loads when I create a schematic

      Here is version when i load the Letter template.

       

      What am i doing wrong?  I am running CS on my brand new new Surface Pro 6 running windows 10

       

      Scott

          • Re: Changing Templates does not work
            sclifford

            Sorry but this old post does not fix my issue!  I did just as the post stated and i still have the same problem!

             

            Scott

              • Re: Changing Templates does not work
                e14softwareuk

                Does the following work for you. In the CS template folder (C:\Users\Public\Documents\Altium\CS\Templates) copy Letter.SchDot to MyLetter.SchDot. Open CircuitStudio and then drag the new SchDot file onto the application to edit. You should be able to delete the existing logo and add your own image.

                In your opening post you refer to errors but the images are missing, it may help if you could edit the post to include the images.

                1 of 1 people found this helpful
                  • Re: Changing Templates does not work
                    sclifford

                    OK ... Peter I am going to have to pay better attention to the extensions on these files, and how to properly load them into CS.  First the ????.SCHDot files are not accessible from within the File pull down menu/Open Document in CS.  This is what got me into trouble, the only way to get the ????.SCHDot files into CS is by dragging them into CS from a window open in File Explore from Windows.  Once I dragged in my case the file I named Letter-Driver.SCHDot from File Explore into CS I was able to get the changes made I wanted.

                     

                    Note once you make the changes to the template one needs to go to there original schematic and right click on the schematic and go under Options, then Document Options to change the default template to the one you just made.

                     

                    I hope this helps others who wont make the same mistake I made in trying to do this in CS only.

                     

                    Thanks

                    For your Help!!!

                      • Re: Changing Templates does not work
                        e14softwareuk

                        Thanks for letting the community know you have got this working and it should be a valuable how to for other CircuitStudio users.

                        • Re: Changing Templates does not work
                          voltsandjolts

                          You can open ".SchDot" files from within CS:

                           

                          File > Open Document > Select extension filter " *.* " (any file) > Pick your SchDot file from the templates directory

                          ... / Public Documents / Altium / CS / Templates

                           

                          Edit it, add your logo.

                          Right Click on logo image > Properties > Select "Embedded"

                           

                          Double click outside the page area to view document options.

                          Select Parameters tab - here is the source of the special strings you can add to your template.

                          Add special strings e.g. "=DocumentFullPathAndName", "=SheetNumber", "=SheetTotal" etc. as required to your template.

                           

                          Save or Save As *.SchDot

                           

                          Change your default template preference in

                          File System Preferences > Schematic > General > Defaults

                           

                          Done.