5 Replies Latest reply on Mar 12, 2019 5:46 AM by kevin014

    Need Windows 10 USB driver for TENMA 72-2930 PSU

    kevin014

      Hi,

       

      I am trying to get my TENMA 72-293072-2930 Programmable DC Power Supply to show up as a USB device so that I can control it in LabVIEW.

       

      I tried installing the USB driver from here, but the device still shows up as "Unknown USB Device (Configuration Descriptor Request Failed)".

      I also followed the instructions from this post, but this didn't solve the issue.

       

      Where I can find the correct USB driver for my PSU?

       

      Thanks

        • Re: Need Windows 10 USB driver for TENMA 72-2930 PSU
          tbartonnewark

          Checking.  I'll see what we can figure out.

          • Re: Need Windows 10 USB driver for TENMA 72-2930 PSU
            lui_gough

            "Unknown USB Device (Configuration Descriptor Request Failed)" normally points to a USB communications issue and is not necessarily driver related.

             

            I'd first try a different cable and see if it resolves the issue. Perhaps try a different port and not going through any hubs. If not, it could be that your particular USB controller has compatibility issues (I've met some devices that just wouldn't work on one PC but were fine on another), so perhaps also try plugging it into another PC.

             

            Configuration Descriptor Request Failed normally means that the USB controller on the PC couldn't request the necessary data to set up the USB device in the first place. The device has to be configured correctly on the bus before a driver can take over, so it's almost certainly a lower-level issue than that of the PSU driver. Perhaps you may need to update the USB drivers for your particular host controller on your PC.

             

            - Gough

              • Re: Need Windows 10 USB driver for TENMA 72-2930 PSU
                kevin014

                Hi Gough,

                 

                Thanks for the pointers. I tried a different cable and different ports, but this didn't fix the issue. I have yet to try this on a different PC with Windows 10 installed so this will be my next step.

                I also have a TENMA load bank which is using a KORAD USB driver, and this is detected and works as expected on all ports.

                 

                I am doubtful if the issue is to do with my laptop's USB controller like you are suggesting as sometimes the PSU shows up with a different name but still cannot be communicated with. I'll have to get it to show up again under this name so that I can post some screenshots here.

                 

                I find it a bit strange that a device advertised as programmable does not ship with a USB driver, and there is no official documentation on the issue.