1 Reply Latest reply on Aug 16, 2019 9:16 PM by grondak

    Beagle bone black is not booting from SD card

    masea0805

      Hi,

      I am using beagle bone black element 14 board interfaced with CAN cape.

       

      I downloaded the Debian 9 from beaglebone website and copied into SD card and tried to boot with boot button key in (CANcape) pressed before power supply but its not booting.

      Actually the BBB is booting fine from eMMC.

       

      When I tried to boot from SD I have observed the user LEDs are not blinking and also no logs in the serial console. I have no idea why it is not booting.

       

      Kindly help me in resolving the issue.

       

      Regards,

      Masea

        • Re: Beagle bone black is not booting from SD card
          grondak

          Hi masea0805

          Did you try to boot the BBB without the cape? The instructions for booting with an SD card remind you,

          If you are using your Beagle with an SD (microSD) card, make sure it is inserted ahead of providing power. Most Beagles include programmed on-board flash and therefore do not require an SD card to be inserted.

          I bet you already did this step, so see how the BBB works without the cape.

          If it still fails without the cape, but boots from the eMMC as you mentioned, maybe the card isn't built correctly? (Debian not copied into SD card properly).

           

          Maybe you can take a video of the failure and I'll compare it to my BBB to help.