1 Reply Latest reply on Aug 8, 2019 9:30 AM by jafoste4

    Lab1.1 on SDK 14.5

    gabrial

      Hello everyone,,

      Has anyone tried to build the Zynq FSBL with the latest Xilinx tools (ISE 14.5)?

       

      I've met several problems already and some I was able to work-around. But I am still not able to have it build.

       

      * In PlanAhead I had to regenerate the bitstream and make sure to also load the implementation. Only then was I able to Export Hardware for SDK including the bitstream.

      * Instead of a Xilinx C Project I had to choose a New Application Project in the SDK.

      * Then it turns out almost all include directories are missing so I right-clicked src->properties and added the following include directories:

        C:Xilinx14.5ISE_DSEDKswlibbspstandalone_v3_04_asrccortexa9

        C:Xilinx14.5ISE_DSEDKswlibbspstandalone_v3_04_asrccortexa9gcc

        C:Xilinx14.5ISE_DSEDKswlibbspstandalone_v3_04_asrccommon

        C:Xilinx14.5ISE_DSEDKswXilinxProcessorIPLibdriverscommon_v1_00_asrc

        C:Xilinx14.5ISE_DSEDKswXilinxProcessorIPLibdriversdevcfg_v2_02_asrc

        C:Xilinx14.5ISE_DSEDKswXilinxProcessorIPLibdriverswdtps_v1_02_asrc

      * You cannot use the (newer) standalone_v3_09_a directory.

      * In fsbl.h I replaced include xparameters.h with xparameters_ps.h

       

      But even after all this it still fails to build with a missing definition for XPAR_PS7_WDT_0_WDT_CLK_FREQ_HZ. I cannot find where this symbol should come from.

       

      Can anybody help me? I'm pretty much lost and feel the only solution is to revert to ISE 14.2. That would mean another big download and another long install.

       

      Kind regards,.