4 Replies Latest reply on Aug 22, 2019 12:45 PM by clem57

    Azure Sphere can't see iPhone Hot Spot

    techyg

      I was able to get through all the steps of the Azure Sphere setup, up until I need to connect to wifi to get the device updated. I am in a locked down corporate environment, and need to use a phone hot spot for development. I am on the latest version of iOS (12.4).

       

      I have tried adding my hot spot SSID using the "azsphere device wifi add --ssid <yourSSID> --key <yourNetworkKey>"

       

      Unfortunately, this does not seem to work, and it doesn't see my iOS hot spot. I checked by running "azsphere device wifi scan" and it does see many other ssid's (that I don't have access to) so I know the wifi is working. I also confirmed it added my ssid by using the azsphere device wifi list command. I do see the SSID from my PC, and am able to connect to it, so I know the hotspot is working.

       

      Based on some google searching, I believe the iOS hotspot is using WPA 2 Personal.  According to the MSDN documentation section "Configure Networking" it says that you need WPA/WPA2. Can anyone confirm that Azure Sphere should be able to use this? Or is there any step I am missing?

        • Re: Azure Sphere can't see iPhone Hot Spot
          kmikemoo

          The Azure Sphere will work with an iPhone IOS 12.4.  I just checked it with my iPhone.  I also did check-ins for a week from the road using it.

           

          After adding my hotspot, I did need to enable it.  After ADD, it was disabled by default.  By doing the azsphere device wifi scan, my phone's "connected" banner pulses to tell me that it's at least pinging the phone.

           

          Hope this helps.

          2 of 2 people found this helpful
          • Re: Azure Sphere can't see iPhone Hot Spot
            clem57

            azsphere device wifi list

            Shows what items are added. Pay close attention to enabled or disabled. Use this if disabled replace # with the number in the list command:

            azsphere device wifi enable -i #

             

            techyg let me know if you have troubles.

            • Re: Azure Sphere can't see iPhone Hot Spot
              kmikemoo

              I decided to try a check-in completely off the iPhone hot spot today.  Laptop on the hot spot.  Azure Sphere on the hot spot.  Parked in a random shopping center parking lot.

              It worked BUT I did have to increase the wait time to about 10 seconds for the Sphere to reconnect to the hot spot. 

              To allow enough time for the check-in program to get my IP, I'm using a PAUSE line in the sk_check.bat file.  Totally another e14 member's brilliance.  Not my own.

                   sk_check.bat

                   .....

                   azsphere device restart

                   echo.

                   PAUSE   <---  Add this to the .bat file and it will wait for you to hit any key so... you can wait as long as you want to complete the script.  Simple and effective for spotty internet.

               

              The pause could also solve the network configuration issue that you've seen.  If the Sphere is slow to get back on the network during restart, you get the "not configured" IP error - but you probably already figured that out.  This second part is really for anyone new to the thread.

                • Re: Azure Sphere can't see iPhone Hot Spot
                  clem57

                  kmikemoo  wrote:

                   

                  I decided to try a check-in completely off the iPhone hot spot today.  Laptop on the hot spot.  Azure Sphere on the hot spot.  Parked in a random shopping center parking lot.

                  It worked BUT I did have to increase the wait time to about 10 seconds for the Sphere to reconnect to the hot spot. 

                  To allow enough time for the check-in program to get my IP, I'm using a PAUSE line in the sk_check.bat file.  Totally another e14 member's brilliance.  Not my own.

                       sk_check.bat

                       .....

                       azsphere device restart

                       echo.

                       PAUSE   <---  Add this to the .bat file and it will wait for you to hit any key so... you can wait as long as you want to complete the script.  Simple and effective for spotty internet.

                   

                  The pause could also solve the network configuration issue that you've seen.  If the Sphere is slow to get back on the network during restart, you get the "not configured" IP error - but you probably already figured that out.  This second part is really for anyone new to the thread.

                  It seems in my limited time with Azure Sphere, the programming for the wireless is on one M4F(Maybe) running at 200 MHz and not the A7 running at 500 MHz. This could account for the slowness. To use DHCP, takes a few interactions to setup the IP address. I have not analysed this to a great degree, but feel confident that is what we are dealing with.

                  Hope this helps.

                  Clem