2 Replies Latest reply on Nov 17, 2019 12:48 AM by leo0815

    EnOcean PI 868 with raspberry PI4

    leo0815

      Is there anything special to get an EnOcean PI 868 mudule running on a rasperry PI 4?

       

      I'm new to the topic and have  just received my brand new raspi + the EnOcean module mentoned above. I've tried to follow all the instructions posted here, read about additional setups necessary for PI3 and tried to do that too. Still I don't see a single byte being received. I've nowhere found anything special about PI4.

       

      Thanks in advance

        • Re: EnOcean PI 868 with raspberry PI4
          shabaz

          Hi Ingo,

           

          From a quick scan of that webpage, it seems that the board uses the serial UART on the Pi. So, there is a chance your issue could be serial port related, since that web page shows a very old 26-pin Raspberry Pi. There were changes (I can't recall the entire specifics) with the more recent Pi's, where the serial port speed varies with clock speed, and swapping of serial interfaces for use with the on-board bluetooth. You may have to dig deeper online to find out more since I can't recall the detail. There are ways to fix that speed via configuration. Anyway that's an area where you may wish to focus on as part of the debugging effort, and also double-checking if /dev/ttyAMA0 exists, or if that should be changed. I don't use the serial port on the Pi enough to know.

            • Re: EnOcean PI 868 with raspberry PI4
              leo0815

              indeed the EnOcean PI 868 uses serial UART gpio 14 &15 and web research always brings me to these points, which are in genereal related to PI 3B but seem to be true for  PI4 too:

              • /dev/ttyAMA0 is by default used for blutooth, /dev/ttyS0 as 'miniuart' for serial
              • you can switch devices by adding dtoverlay=pi3-miniuart-bt to /boot/config.txt
              • /dev/ttyAMA0 is also used for serial if you disable blutooth completely with dtoverlay=pi3-miniuart-bt to /boot/config.txt
              • the simplest way to see if anything is received is by calling 'stty -F /dev/ttyAMA0 (or ttyS0) 57600 (115200 in other posts)' + hexdump -C < /dev/ttyXXX'

              But whtevere I've tried I had no luck