2 Replies Latest reply on Mar 10, 2020 3:02 AM by svonohr

    USB 3 devices only detected with USB 2 speed

    svonohr

      I’m trying to get a USB 3 device working on the UltraZed I/O Carrier Card with an UltraZed-3EG SoM. The device is usually detected, but only as a USB 2 full-speed device. The USB drive I’m using for testing is definitely USB 3 and is detected as such on my PC. It also reports as super-speed capable on the UltraZed-3EG. I’ve tried the prebuild image from the Petalinux 2019.1 BSP, the image from the USB 3 performance test tutorial and images I’ve build myself. None of them run at the USB 3 speed. I’ve seen other reports of people having problems with their USB adapter cable. Mine is supposed to be USB 3 super-speed capable, but I might get a different one just in case.

       

      I’m also confused with the setting of the GTR reference clocks. What clock input is used for USB and what frequency is expected for the prebuild images? I’m assuming it should be 52MHz on REFCLK0. I’ve scoped the REFCLK0 pin and found that the clock was only 26MHz and started testing different jumper settings. Can you confirm that this is the correct way to configure the clock chip?

      • I2C Software Mode: JP1 removed, J1 and J2 placed at positions 2-3
      • Hardware Config: JP1 placed (the IOCC user guide says not placed, but I think this is an error), and J1 and J2 placed at position 1-2 to select mode 3. Other modes can be selected by removing J1 and/or J2.

       

      I’ve tried different configurations and found that they do not match table 13 in the IOCC user guide. Rather I’m observing the following frequencies on REFCLK0:

      • Mode 0: 52 MHz
      • Mode 1: 100 MHz
      • Mode 2: 50 MHz
      • Mode 3: 26 MHz

       

      Since I believe the 52 MHz to be the expected frequency I switched to mode 0, but this also didn’t get me USB 3 speed. What exact clock/jumper settings are required for the prebuild images to work?