0 Replies Latest reply on Mar 8, 2020 3:53 AM by itzikhaim

    eMMC init at Linux

    itzikhaim

      We have a problem when trying to enable the eMMC (soldered-chip)  at picozed (zynq zc702) evalutation board at Linux.

      The board is rev. E.

      We are using an HDF file from our firmware engineer which enabled the ps7_sd_0 and ps7_sd_1 entities. The good thing is that we can fully use the eMMC at u-boot (using mmc tool) -built from Xilinx repo (u-boot-xlnx-2019.01).

      We are building linux kernel 4.19.0 from Xilinx repository and tried various device trees (the deafult disable the eMMC chip)- but non of them are working.

      We get the following error when booting linux:

      mmc1: Got command interrupt 0x00030000 even though no command operation was in progress.
      sdhci: =========== SDHCI REGISTER DUMP ===========
      sdhci: Sys addr: 0x00000000 | Version:  0x00008901
      sdhci: Blk size: 0x00000000 | Blk cnt:  0x00000000
      sdhci: Argument: 0x00000000 | Trn mode: 0x00000000
      sdhci: Present:  0x00ef0000 | Host ctl: 0x00000001
      sdhci: Power:    0x0000000f | Blk gap:  0x00000000
      sdhci: Wake-up:  0x00000000 | Clock:    0x00004007
      sdhci: Timeout:  0x00000000 | Int stat: 0x00000000
      sdhci: Int enab: 0x00ff0003 | Sig enab: 0x00ff0003
      sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
      sdhci: Caps:     0x69ec0080 | Caps_1:   0x00000000
      sdhci: Cmd:      0x0000371a | Max curr: 0x00000001
      sdhci: Host ctl2: 0x00000000
      sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x00000000
      sdhci: ===========================================

       

      We tried the following previously supported answers:

      https://forums.xilinx.com/t5/Processor-System-Design/Zynq-SDIO-via-EMIO/td-p/327479

      https://forums.xilinx.com/t5/Embedded-Linux/Problems-with-using-a-second-SDIO-controller/td-p/442766

      Note that we are not using the SDIO via EMIO (only directly from PS pins/mux).

      Also, tried to add into the device-tree the "wp-inverted;" property as suggested at this forum:

      SDcard not writeable on PicoZed Rev E board (Rev C board works) ?

       

      But still no progress - please your help.