7 Replies Latest reply on Aug 10, 2020 8:50 AM by jamesharrimanaltium

    Supplier extensions

    poobah

      Having trouble downloading the supplier extensions. From the My Acount->Extensions and Updates->Installed_Configure Platorm page. I select DigiKey or Mouser, and then apply.

      Circuit Studio reboots, and I get an error

       

      I am using 1.5.2 (30) and have a valid active license.

      I tried uninstalling / reinstalling the Altium Parts Provider, but it didn't help

      Any Idea?

       

      CS

        • Re: Supplier extensions
          mc6800

          As far as I can tell, Altium have dropped some (all) of the supplier extensions from their web site, apart from the Altium Parts Provider. You can still install them if you have the full offline installer, but the web installer doesn't seem allow this anymore.

            • Re: Supplier extensions
              yzl8z4zcbz48

              I have the exact same issue but I do not understand your answer.  What is an offline installer and how do I get it?

               

              It looks like the Altium Parts Provider is the new method to get part pricing.  The installer  however will not install this option, it says: "This feature is not available for installation.  Probably your subscription has expired.  Is this feature not available with a trial license?

                • Re: Supplier extensions
                  mc6800

                  The offline installer is a ~1.5GB download that was available from Element14/Altium if you asked them for it whilst your subscription was valid - for some unknown reason they don't make it easily available. You will need to email the the support link at Element14 to obtain it, unfortunately.

                   

                  I can't see why the Parts Provider wouldn't be available during the active portion of the trial - is it possible that your trial has expired as well, so it is blocking installation of anything not already installed?

              • Re: Supplier extensions
                nwgarner

                Same issue here.  Any luck getting it fixed?

                • Re: Supplier extensions
                  nwgarner

                  I called the E14 CircuitStudio support phone number, +1 877 7364835 (USA).  After a 20 minute queue wait, as soon as I mentioned, "suppliers aren't working," he interrupted me and said, "you need the offline installer."  Fifteen minutes later I received an email with the relevant information to fix the problem.  He said they are working to fix it.

                    • Re: Supplier extensions
                      calmhands

                      Once you got the email, what did you have to do? I'm in the same boat.

                        • Re: Supplier extensions
                          jamesharrimanaltium

                          Hi Bradley and others,

                           

                          I'm not sure if you solved this problem already.

                          The installer issue was fixed a while ago, however I'll provide instructions here, in case someone here needs to install the Altium Parts Provider, to use now that the older Supplier extensions are no longer operational.

                           

                          Please make sure you are signed in. View > Start takes you to the Home screen, then the My Account drop down will show "Sign out" if you're signed in.

                          Go to My Account > Extensions and Updates and click the Installed tab.

                          Click the grey Configure... link, near the top right of the screen.

                           

                          Enable the option: Altium Parts Provider, and click Apply.

                           

                           

                          CircuitStudio restarts and then the Altium Parts Provider extension is showing on the Installed tab.

                           

                           

                          Go to Preferences: Data Management > Suppliers, scroll to the bottom, and ensure that any checkboxes in the Available Suppliers section are un-checked. These must be disabled in order for the suppliers with the same name, in the top section, to function.

                           

                           

                          Best regards,

                           

                          James Harriman