6 Replies Latest reply on May 10, 2020 9:51 AM by sigurdht

    MiniZed seems very dead

    sigurdht

      I am totally new to zedboards and fpga systems and SoCs like this in general, so sorry if this seems silly:

       

      I was trying to run a hello world project on my MiniZed board when I accidentally diconnected the usb cable from JTAG to my computer (windows 10). After I plugged the board back in it did not any longer run the microphone-to-LED demo program that was there from factory state, and I was not able to communicate anything with it through the tera term serial terminal.

       

      I therefore tried following the factory reset guide Restore QSPI and eMMC Factory Images | Zedboard  . In that guide I at one point execute the command "exec program_flash -f flash_only_boot_7007S.bin -fsbl zynq_fsbl.elf -flash_type qspi_single" in the Xilinx Software Command Line Tool (I have version 2019.1). This command produces the somehow reasonable output:

       

       

      ****** Xilinx Program Flash

      ****** Program Flash v2019.1 (64-bit)

        **** SW Build 2552052 on Fri May 24 14:49:42 MDT 2019

          ** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

       

       

      WARNING: Failed to connect to hw_server at TCP:localhost:3121

      Attempting to launch hw_server at TCP:localhost:3121

       

      Connected to hw_server @ TCP:localhost:3121

      Available targets and devices:

      Target 0 : jsn-MiniZed V1-1234-oj1A

              Device 0: jsn-MiniZed V1-1234-oj1A-4ba00477-0

       

      Retrieving Flash info...

       

      Initialization done, programming the memory

      ===== mrd->addr=0xF800025C, data=0x00000001 =====

      BOOT_MODE REG = 0x00000001

      WARNING: [Xicom 50-100] The current boot mode is QSPI.

      If flash programming fails, configure device for JTAG boot mode and try again.

      ===== mrd->addr=0xF8007080, data=0x30800100 =====

      ===== mrd->addr=0xF8000B18, data=0x00000000 =====

      Downloading FSBL...

      Running FSBL...

      Finished running FSBL.

      ===== mrd->addr=0xF8000110, data=0x000FA220 =====

      READ: ARM_PLL_CFG (0xF8000110) = 0x000FA220

      ===== mrd->addr=0xF8000100, data=0x00028008 =====

      READ: ARM_PLL_CTRL (0xF8000100) = 0x00028008

      ===== mrd->addr=0xF8000120, data=0x1F000200 =====

      READ: ARM_CLK_CTRL (0xF8000120) = 0x1F000200

      ===== mrd->addr=0xF8000118, data=0x00113220 =====

      READ: IO_PLL_CFG (0xF8000118) = 0x00113220

      ===== mrd->addr=0xF8000108, data=0x00024008 =====

      READ: IO_PLL_CTRL (0xF8000108) = 0x00024008

      Info:  Remapping 256KB of on-chip-memory RAM memory to 0xFFFC0000.

      ===== mrd->addr=0xF8000008, data=0x00000000 =====

      ===== mwr->addr=0xF8000008, data=0x0000DF0D =====

      MASKWRITE: addr=0xF8000008, mask=0x0000FFFF, newData=0x0000DF0D

      ===== mwr->addr=0xF8000910, data=0x000001FF =====

      ===== mrd->addr=0xF8000004, data=0x00000000 =====

      ===== mwr->addr=0xF8000004, data=0x0000767B =====

      MASKWRITE: addr=0xF8000004, mask=0x0000FFFF, newData=0x0000767B

      Problem in running uboot

      Flash programming initialization failed.

       

      ERROR: Flash Operation Failed

       

       

      So I understand there is something going wrong with uboot (whatever that means), and I have tried but am not able to get any more detailed debug info about what is going wrong there.

       

      I also want to mention that I have a really bad feeling something is very wrong because everything that happens on the board when I connect it to power is that the LEDs D14(RDY), D2(PS LED), D8(PL LED) and D12 (PWR) light up statically. The reset button has no visible effect and the D3(DONE) LED that should have lit up in blue when the board has booted is not lighting up at all.

       

      In my understanding there must be some corruption in the absolute basics of how the board boots, but is it possible to fix that? In case how??

       

      I would be very grateful for any response on this issue, I am most of all curious of understanding what is going on.

        • Re: MiniZed seems very dead
          gsgill112

          Hi,

          1.   Did you configured the F <BOOT> J connector correctly to emulate JTAG ?

          2.   Did you chek the device manager in Windows and lsusb in Linux to see if the FTDI chip is being recognized ? (You can download the FTDI chip reconfiguration tool for windows and check the FTDI connections. BUT DO NOT WRITE ANYTHING BACK AS THEN YOU WILL PROBABLY BRICK YOUR KIT)

          3.   Check that Proper FTDI Drivers are installed before hand.

           

          Regards,

            • Re: MiniZed seems very dead
              sigurdht

              1. Yes, and I have tried both configurations many times. According to the reset guide I should boot from the flash, so that is what I did to produce that output, but it is the same output with both actually.

              2. Yes, I checked that now and it is being recognized as "USB Serial Port (COM19)". Can you send me a link for the FTDI reconfiguration thing, if that is still important? I am not sure how to find that myself.

              3. Yes, as far as I can see, all the drivers are installed successfully on my computer. I would just mention that I used to communicate perfectly with it before I accidentally unplugged it.

               

              I have also thought about the probabilities of ESD now, since I was just coming back from eating and didn't think about discharging myself before working further with it... I am a newbie to fpgas and don't really know how that usually happens.

                • Re: MiniZed seems very dead
                  gsgill112

                  Hi Sigurd,

                  Sorry for late reply, I am uploading my configuration file and linking the Programming software https://www.ftdichip.com/Support/Utilities.htm#FT_PROG

                   

                  Sorry I am not sure weather this editor is allowing me to upload the files, email me [Pl Visit gsgill112.github.io] and i will forward that. Though I am not sure how helpful will that be

                   

                  Avnet seams to have added ESD protection for USB and JTAG Usb poorts and a diode protection for the other usb port as per the datasheet, Can you confirm if the power rails are working ?

                  1. Try using a multimeter, get a schematic and poke around the USB and the PMIC section to verify the correct voltages.

                  2. If you dont have a multimeter a crude way is using a led with some 100Ohm resister in series stick the -ve terminal to ground and start probing the 3v3 / 5v Rails.

                  3. With a multimeter check for VCC to Ground Shorts ( you can also touch components and feel is one of them is burnt or is getting really hot)

                  4. If all of the above tests have failed, You can try powering the board from 3v3/ 5v  rails on the PMOD  to check if at least the power led turns on and nothing get the magic Smoke or overheats.

                   

                  as per the a/m tests we can try and figureout what is wrong with the board that is.

                   

                  regards,

                  1 of 1 people found this helpful
                    • Re: MiniZed seems very dead
                      sigurdht

                      I think it was very hard to understand much of what you said, but I have tried a few things:

                       

                      Firstly I downloaded the program you linked and pressed "scan and parse" and got the exact same configuration and output as you. Then I randomly tried the "program" button and think I reprogrammed it, and the configuration was still the same, but slightly different output. It doesn't seem like it fixed the board either. All LEDs still just light up like before boot.

                       

                      Then I tried your tests:

                       

                      1. I got this schematic: http://zedboard.org/sites/default/files/documentations/MiniZed_Rev_1_Schematic.zip and tried measuring voltage from GND to PMIC_GPIO3 and from GND to PMIC_GPIO4. Both voltages were 0. I also measured from GND to VBBAT and that voltage started out around 3V but immediately started decreasing when I measured it and soon got very close to 0V. I don't know really what this means, for my board, hope you can help a bit here... I also don't know how to interpret what I measured on the USB section: There the FT_PWRSAV_N has 0V, which was the only pin I could find accesible on the board.

                       

                      2. I have a multimeter. All constant voltage pins I could find also have the voltage that is written on them.

                       

                      3. I can not find any shorts from GND to a not GND pin. I can not see any very burnt or feel any very hot components.

                       

                      4. Ok, maybe interesting... I tried powering the board only from PMOD using 3.3V and all LEDs light up, including the blue one (DONE) which is not lighting up when powering from USB. I can not see any smoke, but after only 5 seconds my power supply (a digilent analog discovery 2) cuts of due to overcurrent.

                       

                      So, thanks for coming back to me, I tried mye best doing what you said, and I hope you understand what these results mean, because I do not understand what it means.

                        • Re: MiniZed seems very dead
                          gsgill112

                          Hi Sigurd,

                           

                          Seems like there is a Power failure occurring or a short somewhere in the device, because of which the current limit is reached.

                          Unfortunately someone with a decent electronics knowledge needs to see the board to figure out the short or a bad component (as you said that nothing is overheating ; i.e. more warm to touch than regular ICs. )

                           

                          That being said I will give you few tips that can help you find the faulty component / bug on the board. Refer the above Images.

                          (Avnet has designed the board quite nicely so that all the component labels are on the board as well as the necessary test signals )

                           

                          Firstly,

                          We will try to ascertain if the main power path is continuous OR not. I.e Power is reaching the main Dialog chip or not.

                          To do that see the White arrows in the First and the Second Images, all of them corresponds to 5V from the Aux Input that is the CLOSEST to the PS BUTTON.

                          (DONT POWER YOUR BOARD AT THIS TIME ) Just fix one of your multimeter ends to TP16 (5V is written there) and sequentially probe other white marks with other leads IN CONTINUITY MODE. If you hear a beep from Multimeter, its good, go to next one.

                           

                          Assuming that there is continuity moving on

                          Secondly,

                          We Will probe the Input Power Signals (DO THIS CAREFULLY) as a wrong touch to other component will definitely kill the PMIC .

                          To be safe we will only probe 2 places i.e. D13 the Big Diode near the Aux Power USB Source. and the TP16

                          So, first connect the Black /COM probe to GND (anywhere) or just connect it to TPG1( GND Written there ) and set it to Voltage Mode with 20V range

                          connect power to the Aux USB Port.

                          second : probe D13 at the point just below the usb connector (without the Grey band) your multimeter should read ~5V DC.     :     IF you read a 0 here most likely there is a issue with solder joints on the USB port / D13 might be off.

                          now probe the other part of the diode i.e the place with Grey band (Marked on the above images ) and you should still read 5 V DC.      :     IF you read a 0 here most likely there is a issue with  D13 and it has been blown. Most likely due to ESD.

                          now probe the TP16 point. You should get 5V DC,      :     IF you read a 0 here most likely there is a issue D13 as mentioned above or some of the small Capacitors protecting the Input side of the PMIC might be off.

                          IF at any given location the voltage is fluctuating, then most likely the Caps are to be blamed and that may be  beyond a beginner to diagnose or fix.  

                          IF D13 is short or the Input filtering caps are gone, most likely, PMIC might have suffered some blow and that can be partially diagnosed by checking the Output side.

                           

                          Now with this Knowledge , try diagnosing the Output side, start by the 3.3V in the similar fashion  which is the Main power rail to all other ICs on the board. 

                          Start with continuity testing on the signal marked by yellow in the above image and refer the datasheet screenshot attached.

                           

                          NOTE : probe only the GREEN BOXES marked in the schematic to save time , the red ones are most likely not the culprit (but can be ) So Happy Hunting.

                           

                          Regards,

                          GS Gill

                          P.S. Interested in Projects Pl visit me @ gsgill112.github.io

                          Subscribe to my youtube ; All my codes are available on my github

                          Want to contribute to my projects, why not start here TechNERVERS

                          2 of 2 people found this helpful
                            • Re: MiniZed seems very dead
                              sigurdht

                              Thanks again for helping, and sorry it took a few days before I tested this.

                               

                              Firstly,

                              The multimeter beeped nicely on all connections from TP16 to the components you pointed at in the pictures.

                               

                              Secondly,

                              I connected the aux pwr USB and measured voltage from the side without grey band and got 4.90V, and on the grey band side I got 4.68V. And at TP16 I measured 4.68V. So, I guess this part is all good. None of the voltages are fluctuating.

                               

                              When it comes to the output side I am not sure if I found all the connections to check, because I only found TP14 to R110. But I checked that one, and it was all good.

                               

                              But is it possible that it is a short from any of the power signals, when they all have the correct voltages when powered by USB? I know I get overcurrent when powering only 3.3V directly on the 3.3V pin (or the PMOD, which is just directly connected to 3.3V), but if I do that while the board also is correctly powered from USB, there is no overcurrent.