9 Replies Latest reply on Apr 27, 2020 11:20 AM by ontran

    Display Port issue on Ultrazed 7EV SOM+Carrier Card

    ontran

      We bought two Ultrazed 7EV SOM+Carrier Card starter kits. I cannot get the display port to work with the shipped SDCARD as is, and looking for some help.

       

      I followed the avnet 7ev cc test document and display port config document from gitlab. I also have a ZCU106 that worked with the same display-port cable+monitor for comparison.

       

      (1) Ultrazed didn't seem to have a drm (Direct Rendering Manager) driver:

       

      root@uz7ev-evcc-2017-3:~# drmdevice
      drmGetDevices() has returned 0

       

      On ZCU106:

       

      root@zcu106_vcu_trd:~# drmdevice

      device[0]

         available_nodes 0001

         nodes

      ... [lots of stuff]

       

      (2) Ultrazed has a different device name

       

      root@uz7ev-evcc-2017-3:~# ls -al /sys/class/drm/card0/device
      lrwxrwxrwx 1 root root 0 Feb  6 23:32 /sys/class/drm/card0/device -> ../../../xilinx_drm

       

      On ZCU106:

      root@zcu106_vcu_trd:~# ls -al /sys/class/drm/card0/device
      lrwxrwxrwx 1 root root 0 Feb  4 07:13 /sys/class/drm/card0/device -> ../../../fd4a0000.zynqmp-display

       

      (3) I was able to get colorbar show up on the monitor at 1920x1080 on ZCU106, but the two Ultrazed boards showed different behavior, one has no resolution (return nothing) when poked with "$ cat /sys/class/drm/card0-DP-1/modes", the other board returns "1366x768" and others, but no 1920x1080. I was able to get colorbar on Ultrazed with resolution of 1366x768 with "modetest ...". This might be an EDID issue?

       

      Anyone got the display port working with the board as is? Any comments or advice are appreciated.

       

      Liyong Z

       

        • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
          drozwood90

          Hi there,

           

          Have you seen this design?

          UltraZED-EV + IO Carrier Card VCU Design Example (v2018.3)

           

           

          That will link you over to some pre-built images that you can test rather quickly based on the instructions on that same page.

           

          I've personally used that image in my webinar if you would rather see how to run this demo using video instructions

          Embedded Video Processing Using the UltraZed-EV

           

          --Dan

          1 of 1 people found this helpful
            • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
              ontran

              Hi Dan,

              thanks for the quick response.

              Yes, I was following reference design example v2018.3 and went through your youtube video series. We are trying to reproduce what you did step-by-step. Thanks for all the great documents. The commands I was using in above post were coming from "Configuring and Working with the DisplayPort Interface" as shown in your post.

               

              I have also tried to use the "pre-build" images in the design example to put on a sdcard. It behaved the same.

               

              I did notice that in your video, the prompt is

                root@vcu_uz7ev_cc:~#

              while the shipped sdcard boots up as (is it supposed to 2018 something?)

                root@uz7ev-evcc-2017-3:~#

               

              Regards,

              Liyong

            • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
              drozwood90

              Hi Liyong,

               

              I can't be 100% sure this is your issue, but that nugget of information leads me to believe you do not have your boot switches set properly.

              The board ships from the factory setup for QSPI boot.  That factory test image is from 2017.3.

              You need to change the boot jumpers on the SOM to be SDCARD Boot.

               

              Left to RIGHT as depicted in the below image

              ON OFF OFF OFF

               

              --Dan

              Also, it appears that once I flipped my phone into MACRO view, that I need to clean my SOM - didn't get a dusting when I was cleaning my office!

              1 of 1 people found this helpful
                • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
                  ontran

                  Hi Dan,

                  You are right! I was able to get through with the dip switch settings.

                  Some minor questions:

                  (1) why does it say open device of 'i915' as shown below? Is it supposed to be GPU Mali? i915 is an intel GPU.

                   

                  root@uz7ev-evcc-2018-2:~# modetest -D fd4a0000.zynqmp-display -s 38@36:1280x720-60@AR24

                  trying to open device 'i915'...done

                  setting mode 1280x720-60Hz@AR24 on connectors 38, crtc 36

                  [   46.103226] PLL: shutdown

                  [   46.112613] PLL: enable

                   

                  (2) I have a 4K monitor. I could recognize that on ZCU106, but only 1920x1080 on Ultrazed. Was there some limitation on the display port hardware of carrier card or SOM?

                   

                  Much appreciate your help!

                  Liyong

                    • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
                      drozwood90

                      Hi there,

                       

                      1) let me check - it could just be a "goofy" linux driver  thing.  To be honest, I had never noticed that.

                      2) while the UltraZed-EV SOM supports 4K2K, the CURRENT Carrier does it using a SINGLE lane.  There are FEW monitors out there that support the full 4K in a single lane.  Thus we see almost all monitors we attach run at 1080P.  There are things in the works regarding this, but the solution you have right now (as it was explained to me) is get a really expensive monitor that can support a single lane 4K2K or live with 1080P while using our current carrier card.  A custom carrier would solve this issue.

                      2 of 2 people found this helpful
                      • Re: Display Port issue on Ultrazed 7EV SOM+Carrier Card
                        narrucmot

                        Hi Liyong,

                         

                        The UltraZed may not recognize the high resolution of your 4K monitor because it is limited to just one lane of DP video.  Here is a screenshot from DP connector in the schematics:

                         

                         

                        It is my understanding that UHD or 4K video requires 2 lanes of DisplayPort.  If this is a requirement you may want to take a look at the UltraZed-EG SOM with the I/O carrier.  The Zynq MPSoC device on the UltraZed-EG SOM has a smaller PL and doesn't have the VCU that the UltraZed-EV does, but if you need 4K video this may be an option for you.  Keep in mind only the UltraZed-EG I/O carrier has two lanes of DP video.

                        --Tom

                        2 of 2 people found this helpful