6 Replies Latest reply on Jun 3, 2020 3:33 PM by gdstew

    BBB's serial port is not receiving any data.

    jmseo153

      Hello,

       

      I have a problem in my BBB(BeagleBone Black) board.

       

      I received BBB today. So I tried to test. First of all, I checked serial port for debug.

      I could see boot logs with putty.

      However, I could not enter any input though the serial uart. It seems that there is some problem in UART connection.

      Shortly,

      TX of BBB's Serial UART is working. RX of BBB's Serial UART is not working.

      It seems like hardware's problem.

       

      My USB TO UART Converter is working well for Raspberry Pi.

      So I don't think my USB TO UART Converter has problem.

       

      Could you let me know how I can fix it? Should I update software?

      And, I would like to know how return my board.

       

      Thank you.

        • Re: BBB's Serial port is not working.
          Christopher Stanton

          What settings are you using to communicate with the BBB?

            • Re: BBB's Serial port is not working.
              jmseo153

              I didn't change any setting.

              Once I got the board, I started testing without any change.

              Debian Linux and u-boot have already been installed in the board. I just used it.

              Should I change GPIO setting for serial debug?

                • Re: BBB's Serial port is not working.
                  gdstew

                  Are you using an SD card or the on board eMMC? If you are using a SD card and Linux on your PC you can check some of

                  the things below by inserting the SD card in a reader and opening the files to read them. The uboot configuration should be

                  in the MSDOS format partition /boot directory. /etc will be in the Linux formated partition / directory. If you are using Windows

                  you should at least be able to look at the /boot directory.

                   

                  During uboot there will be a (very) short pause after it displays a message to press any key to stop the boot process and enter

                  the uboot command line. When you see that message press a key and it should stop the boot process and display a uboot prompt.

                  The length of the pause can be configured but it is usually set at one second so you need to be quick and you may have to do it

                  more than once. If it does stop booting and displays the uboot prompt then it shows that the receive side of the UART does work

                  and you should then be able to enter a uboot command. Try help and it should then print a list of the available uboot commands.

                   

                  One reason it the serial terminal receive may not work after Linux boots is that it may not have permission to be used as a

                  secure terminal. In a sysvint (non-systemd, it may have the file too) Linux/Unix there is a file in /etc called securetty which

                  contains a list of terminals that can be used by root. If the BBB's serial terminal is not in that list it will ignore anything entered

                  from it. Its been a while since I needed to do that so I don't remember if it will display the login message or not.

                   

                  Another reason is that the command line used to boot Linux does not include a parameter to use the serial port as the console

                  terminal. I'm pretty sure it does but I thought I should mention it.

                  1 of 1 people found this helpful
                    • Re: BBB's Serial port is not working.
                      jmseo153

                      Thank you for your reply.

                      I have already mentioned that I can see boot logs.

                      It means that boot argument is set correctly.

                       

                      You are right. In order for u-boot to stop boot process, we need to enter any key in the short time.

                      However, I cannot enter any key input at the time.

                       

                      My problem is...

                      I can see boot and kernel logs. However, Serial port is not receiving any data.

                      So, I cannot give BBB any command.

                        • Re: BBB's serial port is not receiving any data.
                          gdstew

                          I know what you say the problem is. I want to be sure it is a hardware problem and not a Linux configuration problem.

                          Seeing Linux kernel logs and boot messages on the serial port does not mean that it is not a Linux configuration problem as

                          it can display boot information to any console hardware and then switch to a particular console for log in. If it switches to an

                          on board SoC graphics console it will not accept serial input for the console and instead look for keyboard input on the USB

                          port. There is another Linux configuration file in /etc called inittab (sorry, I forgot about that one) that determines which

                          hardware is used for console after booting.

                           

                          You say now that you can not enter a key at the (that?) time but you never said before that you tried to stop it from booting

                          during u-boot. From what you say now I could assume that you did, I would prefer not to.

                           

                          Oh, I just though about this. Have you tried entering ^s (ctrl s) to stop and ^q (ctrl q) to start the boot messages while Linux

                          is booting? Some times it takes a little time to act on these but it is easier than trying to get to the u-boot prompt.

                          1 of 1 people found this helpful
                  • Re: BBB's serial port is not receiving any data.
                    jmseo153

                    Resolved by myself.

                     

                    When I connected 3.3V in BBB to my USB TO UART Converter as reference voltage input, UART input started working.

                     

                    When I used the USB TO UART Converter for Raspberry Pi, I did not need to do that.

                    I think that Rasp pi and BBB, they are using same IO level, which is 3.3V.

                    Interesting.

                     

                    Anyway, Thank you.

                    1 of 1 people found this helpful