7 Replies Latest reply on Jun 13, 2020 10:02 PM by wolfgangfriedrich

    NAS mount on RPi

    wolfgangfriedrich

      Hello community,

       

      I am having an impossible time trying to permanently connect my NAS to the RPi.

       

      The RPi can see and connect to the NAS through the 'FileManager' menu Go>Network,like this:

       

      Trying to use 'sudo mount' or adding an entry to the /etc/fstab file does not work for me.

      Examples:

       

      pi@raspberrypi:~ $ sudo mount //192.168.2.21/ls-wsgl5ab/Daten /home/pi/Daten/ -o user=Wolfgang,password=xxxxxx
      mount error(112): Host is down
      

       

      Entry in fstab:

      //192.168.2.21/LS-WSGL5AB/Daten /mnt/RPiNAS cifsusername=Wolfgang,password=xxxxx   0  0

       

      I have looked at a lot of forums and pages, they all say that it should work that way.

      So I am guessing that I am missing something else.

       

      What I don't understand, that one part does see the NAS, the other just does not want to cooperate. Welcome to Linux, I know.

      Did anybody have similar issues or a solution?

       

      For crying out load.

      Thanks,

      - Wolfgang.

        • Re: NAS mount on RPi
          shabaz

          Hi Wolfgang,

           

          I don't know the answer, but I know how you can move the scenario to something which may have more success:

          Set up your NAS for NFS file share instead. There should be an option somewhere to configure shared folders, and you can then select NFS.

           

          Then, you can type (as root user) something like:

           

          mkdir /mnt/share
          mount -t nfs ipaddr_of_nas:/volume/share /mnt/share -v
          

           

          where /volume/share can be replaced by the name configured or supplied by the NAS. The '-v' will help you troubleshoot if this doesn't function.

          2 of 2 people found this helpful
            • Re: NAS mount on RPi
              wolfgangfriedrich

              Hello shabaz,

               

              This is a very good lead.

              My NAS is an older model (still using IDE drives ) and it seems like it does not support NFS file share. Here are the setup options. I might be SOL for this one.

              Here is the answer to the mount command:

               

              pi@raspberrypi:~ $ sudo mount -t nfs 192.168.2.21:/LS-WSGL5AB/Daten /mnt/RPiNAS -v 
              mount.nfs: timeout set for Sun Jun  7 21:48:49 2020
              mount.nfs: trying text-based options 'vers=4.2,addr=192.168.2.21,clientaddr=192.168.2.24'
              mount.nfs: mount(2): Invalid argument
              mount.nfs: trying text-based options 'vers=4.1,addr=192.168.2.21,clientaddr=192.168.2.24'
              mount.nfs: mount(2): Connection refused
              mount.nfs: trying text-based options 'addr=192.168.2.21'
              mount.nfs: prog 100003, trying vers=3, prot=6
              mount.nfs: portmap query retrying: RPC: Unable to receive
              mount.nfs: prog 100003, trying vers=3, prot=17
              mount.nfs: portmap query failed: RPC: Unable to receive - Connection refused
              
              

               

               

              I'll keep digging.

              Thanks,

              - W.

                • Re: NAS mount on RPi
                  shabaz

                  Hi Wolfgang,

                   

                  It may be worth trying your original mount command in your first post, but with -t cifs (as well as the -v) because the 'Host is down' error could be a symptom of an attempt to DNS-resolve the string of IP address and path. Maybe explicitly indicating cifs may solve it. I'm only guessing though, I have not done this.

                  It is unfortunate there is no NFS setting in the NAS, it is a 1980's method. Maybe the developers considered NFS too old.

                  2 of 2 people found this helpful
                    • Re: NAS mount on RPi
                      Problemchild

                      Something like below like Shabaz intimates  force the FStype with -t option afterall your Linux system isnt a mind reader and will assume NFS otherwise, make sure you have the SAMBA and Exfat stuff loaded in aswell

                       

                       

                       

                      mount -t cifs //10.10.1.100/share -o username=myUser,password=myPassword /mnt/win1

                      1 of 1 people found this helpful
                        • Re: NAS mount on RPi
                          wolfgangfriedrich

                          To close the loop: the -t cifs option did not work either. Still getting the

                          mount error(112): Host is down

                           

                          I am almost ready to give up.

                          - W.

                            • Re: NAS mount on RPi
                              wolfgangfriedrich

                              shabaz @John_Alexander

                              Sometimes giving up brings the solution:

                              sudo mount -t cifs //192.168.2.21/Daten /mnt/RPiNAS -o username=Wolfgang,password=*********,vers=1.0
                              

                               

                              I This command worked and the issue was from the beginning that I referenced my NAS as //192.168.2.21/LS-WSGL5AB/Daten, when the correct form was //192.168.2.21/Daten .

                              Who knew...

                              I am sure the -t cifs option also helped, not sure if I want to play around with it.

                               

                              Now I just have to enter this into the fstab and everything is perfect. Famous last words....

                               

                              Cheers,

                              - W.

                          • Re: NAS mount on RPi
                            Problemchild

                            Shabaz most toy NASs wont even think of NFS as really it's not their market share NFSv4 is thoroughly modern other wise you could call CIFS 80-90's . Since this is mostly directed to Windows Clients no reason to support NFS it might scare  people ;-)