1 Reply Latest reply on Jul 22, 2020 10:14 AM by tschesnok

    Using Vitis Prebuilt Platform: VAdd/Hello World Demo can't find XRT on device

    tschesnok

      What might I be doing wrong?

       

      I decided to try out the platform "Ultra96-V2 – Vitis Platform 2019.2" rather than build one from scratch.

       

      1. I launched Vitis and imported the platform.

      2. I started a new application - and selected the platform (which showed up in my platform list! Yay.)

      3. I chose the vadd demo code.

      4. I built the application for hardware (12 min).. and I got the following files under SD card:

       

      binary_container_1.xclbin, Boot.bin, MyApp.exe, image.ub, footfs.tar.gz

       

      I setup an SD card with two partitions and copied the bin and ub to the boot partition and uncompressed the rootfs to the second one. (Note: you need to end up with /<linux folders> not /rootfs in the root drive.. )

       

      It boots - yay..

       

      I "export XILINX_XRT=/usr"

      I "./myApp.exe binary_container_1.xclbin

       

      And get [XRT]: Device Not Found

       

      Since it can't be that the platform would build PetaLinux without XRT.. I must have done something wrong.. but the steps to get to what I did are limited.. any ideas?

       

      Also - why can't ANYTHING made my Xilinx just work.. it seems any hello world example online is 200+ steps and has actual errors in it requiring patches and workarounds...

        • Re: Using Vitis Prebuilt Platform: VAdd/Hello World Demo can't find XRT on device
          tschesnok

          Follow on Info: Some good news.. I downloaded the pre-built vadd project and I get the same error. The my mistake must be simple..

          I compared file sizes and they are all identical. So I was building the project correctly.

           

          Here are my exact steps with the prebuild vadd:

          1. I use fdisk to create 2 partitions.. one for 1 gig and bootable - fat, one for 13 gig Linux FS. formatted.

          2. I copy the bin and ub onto the bootable

          3. I expand the FS onto the 2nd partition

          4. I copy u96v2vadd,exe to /home/root so I have it in my home directory (this is ok, right?)

          5. I do the same with the .xclbin file.

          6. I wait for the card to eject correctly after syncing.

           

          I boot the 96v2 with the SD card. I log in root/root

          I "export XILINX_XRT=/usr"

          I run the app... and get the error. All final steps can be seen on screen shot.

           

           

          Should this not work???