5 Replies Latest reply on Sep 1, 2020 3:47 PM by skruglewicz

    Azure Sphere Tenant not Found

    nafihahmd

      Hi friends,

      Me and my sister had bought Avnet Azure Sphere devices; one for each. We were successful in setting up tenants (from our personal accounts) and claiming the devices. We were able to run a simple blink sketch on the Az sphere. Then we both became busy and forgot our Az spheres. Now recently I was doing project in Secure IoT and suddenly remembered Az sphere and tried to use it. I downloaded the latest SDK (not knowing the new changes) connected my Az sphere and tried to logged in with my account. But to my surprise it showed the following warning.

       

      warn: You don't have access to any Azure Sphere tenants.

      warn: Type 'azsphere tenant create --name <name>' or, if you have used Azure Sphere before, type 'azsphere tenant migrate'.

       

      I tried migrating and was greeted with the following error:

      Selected user account does not exist in tenant 'OsTechnology' and cannot access the application '0b1c8f7e-28d2-4378-97e2-7d7d63f7c87f' in that tenant. The account needs to be added as an external user in the tenant first. Please use a different account.

      At this point I asked my sis to give a try thinking that I was using the wrong account (Although I had the mail from microsoft regarding the creation of the active directory in my mailbox). She also a faced the exact same issue. Both of us can login into our Microsoft azure account and see an Active directory that is expired in our account.

      What exactly is happening? More importantly how can we get over this issue?

      Hope somebody here already knows what our issues is. I will be very happy and thankful if somebody can assist us.

        • Re: Azure Sphere Tenant not Found
          BigG

          I suggest raising this issue on the Microsoft forum (just make sure to use the correct Azure-Sphere tag): https://docs.microsoft.com/en-us/answers/questions/ask.html

            • Re: Azure Sphere Tenant not Found
              nafihahmd

              Thank you very much for the fast reply. I have  raised the issue there aswell.

              1 of 1 people found this helpful
                • Re: Azure Sphere Tenant not Found
                  skruglewicz

                  Hi Naflh

                  I ran into the exact same problem with the tenet after upgrading both

                  the OS and SDK to a new version. The OS was version 19.9, but not sure the version of the SDK. I seem to remember trying to set the new Debugging mode with the  the new CMD "azsphere dev enable-development".  I'm not sure what broke this, but I worked on it for hours to get my tenet back. I found no help in the Microsoft docs but found some fragment on the Internet,

                   

                  I recall I needed to re-select the tenet on the board. Somehow the board lost the tenet it was connected to . What a pain in the Butt. This issue would be a disaster in the field, I do hope they address this issue.

                   

                  Anyway you will  to run some commands from the board from the console.

                  1 azsphere logout

                  2. power of the board.

                  3. azsphere login

                  4. azsphere tenent list

                  5. azsphere tenent show-selected

                  6. azsphere tenent select <tenentID>

                  7.azsphere dev enable-development    

                   

                  I have 2 tenents on the same Azure account, so it was a matter of determining the correct device ID to the correct TenentID relationship. You might want to write this relationship down somewhere.

                   

                  Hope this works for you. Let me know you results.

                    • Re: Azure Sphere Tenant not Found
                      nafihahmd

                      Thanks. I will try it and reply.

                       

                       

                      Update:

                      I tried it and the previous issue persists. When I try to login it will say I do not have any tenants in the selected account .

                       

                      Anyway thanks.

                      1 of 1 people found this helpful
                        • Re: Azure Sphere Tenant not Found
                          skruglewicz

                          Once a tenet is created on an account it is connected forever I believe to that account f. This is done one time when initially you create a tenant. Security is a bitch!  Mentally go over your unboxing notes to see where and How your account was created.

                          They made a lot of changes to the OS since the ist version I started with(18.0) to the current version 20.08

                           

                          Seems like your not using the correct account. DO you still have access to the account you created the tenet with?

                          I seem to recall seeing some other members having account problems.

                          Sorry I couldn't be of more help.

                          This is a real tightly secure chip. I've been having a tremendous amount of agony with it.

                          best of luck to you