1 Reply Latest reply on Feb 25, 2021 12:02 PM by doncstokes

    pi-desktop no longer boots from SSD

    doncstokes

      I have a Raspberry Pi V3 in a Pi Desktop case with mSATA SSD installed. I did an apt update & apt upgrade recently and my pi-desktop stopped booting. I removed the ssd, inserted it into a mSATA/USB adapter and re-imaged it with the most current Raspberry Pi OS (Release date: January 11th 2021). I can boot the pi from this external mSATA/USB adapter, but I get a kernel panic when the internal mSATA adapter is used for booting the same SSD. Is anybody else still using the pi-desktop with mSATA boot?

      I have attached a photo of the kernel panic.

        • Re: pi-desktop no longer boots from SSD
          doncstokes

          Solution:

          I inserted an sdcard and booted the pi with the SSD installed. Then I imaged the SSD using the built in mSATA adapter instead of a different adapter. I shutdown the pi, removed the sdcard and booted off the SSD. Everything worked. It seems that writing the SSD with a different adapter created an image on the SSD that was incompatible with the built in adapter. That makes no sense to me, but this solved the problem.