4 Replies Latest reply on Apr 8, 2021 7:36 PM by jomoenginer

    Avnet Ultra96 V-2 booting problem

    achbou6

      I was normally booting my Avnet Ultra96 V-2 from SD-card but today surprisingly no more.

      Current behaviour:

      - I am booting from the same SD card  and the switch is correctly configured

      - No output on the serial Interface

      - The Led D5 INIT(red) is always illuminating

      - The led D2 3,3V (Green) is always illuminating

      - The led D1 (DONE) is never illuminating

      - the leds D3,D4,D6,D7 always illuminating

      - Clicking on the button SW4 (PWR_BTN) doesnt trigger a restart (I guess so because I remarked that the leds are always illuminating).

      I tried to change the SD-card but the same status remains.

       

      I tried to boot it from JTAG using petalinux-boot --jtag --prebuilt 3 --verbose, it ends up with the error "no targets found with "name = ~"*PSU*" . available targets :

      1 PS TAP

      2 PMU

      3 PL

      4 dummy_dap

      Can you please give some hints too debug the problem, that would be really helpful.

        • Re: Avnet Ultra96 V-2 booting problem
          narrucmot

          Hi Achraf,

           

          I have see SD cards become corrupted, and thus unbootable.  Do you have another SD card you can try?

           

          Also, rather than using the prebuilt option for PetaLinux JTAG boot, can you try simply booting to u-boot instead?:

          petalinux-boot --jtag --fpga --bitstream ./images/linux/system.bit --u-boot

          (don't forget to move the boot mode switch to JTAG!)

           

          This obviously won't boot the full OS image, but it can be a quicker test that the processing system and programmable logic are OK.  I have see that the prebuilt option does not always work as desired or expected.  If you can get to a u-boot prompt there is a good chance the hardware is OK and you can focus debug elsewhere.

           

          --Tom