3 Replies Latest reply on Jun 3, 2021 6:30 AM by Christopher Stanton

    Beaglebobe Black Static IP rentention

    prasanna_1812

      Dear All,

       

      I am using Beaglebone black device as an Energy Monitoring device in my IOT Projects. The application reads data through USB (Modbus RTU) and sends it to remote cloud through MQTT. There are around 15-20 Beaglebone Black devices such devices. To access, the internet, the plant IT Manager has given me (15-20)number of static ip addresses. I have set static ip address in the (/etc/network/interfaces) file. But sometimes, the internet connectivity is not working. when i debugged it, i found that beaglebone black is getting dynamic ip address.

      There are separate ranges for static and dynamic ip address in the plant. If i reboot the beaglebone black, it again catches the static IP address properly and the system works normally.

      I am facing this issue in random ip address. As of now there is no option of shifting it permanently on the dynamic ip range. This is occurring in random devices. Please help me resolve this issue. I am attaching the screenshots of ip set in the (/etc/network/interface) file and ip address received.

       

      for example, the static IP address set in the device,

       

      IP: 10.12.4.152

      netmask: 255.255.254.0

      gateway: 10.12.4.1

       

      IP Address received (checked using ifconfig command)

       

      IP: 10.12.4.207

      netmask: 255.255.254.0

       

      I have attached two separate images of configuration done in the beablebone black. one image is /etc/network/interface file and the other is response of ifconfig command.

       

        • Re: Beaglebobe Black Static IP rentention
          Christopher Stanton

          Ubuntu has a network manager which it runs by default and overrides /etc/network/interface.

           

          The best way is to set your static IP address via your DHCP server, called a 'reserved address', that way you'll always get the same IP address.

           

          Otherwise you have to either set your IP address via the network manager in Ubuntu or disable the network manager.

          2 of 2 people found this helpful
            • Re: Beaglebobe Black Static IP rentention
              prasanna_1812

              Hi Christopher,

               

              Thank you for your response. By network manager you mean the connman utility ? On some other communities, i received suggestions such as

               

              1. Setting static IP using the connman with the help of command

              connmanctl config ethernet_d436390d4dcb_cable --ipv4 manual 192.168.0.192 255.255.255.0 192.168.0.1.

              I did manage to set it but it required me to to do nameserver settings manually

               

              2. Second suggestion was removing connman from the system completely so that /etc/network/interfaces could act normally. I tried this one and testing it in my local device. so far, it is working fine, but nor sure how it will work out in the remote devices. Also would like your opinion on point no 1 and 2.

               

              Thanks again.