0 Replies Latest reply on Jun 9, 2021 10:53 AM by 3d_srv

    bluetoothctl disconnects immediately after pairing successfully

    3d_srv

      Hello,

      I'm currently running the Murata's 1DX Wi-Fi and Bluetooth module to the ZedBoard.

      I have a connection problem with Bluetooth: I would like to connect the ZedBoard with my Android phone.

      I can see that everything is OK on the ZedBoard side, concerning the hci0 configuration.

       

      The serial port used is /dev/ttyPS1 for bluetooth initialization.

      hciconfig.png

      Then I run "bluetoothctl" and I can start the initialization:

      scan on.png

      And finally, I "scan on". I can see the ZedBoard on my phone, and the ZedBoard is able to see the smartphone. Everything is OK here. 

      I put "trust xx:xx:xx:xx:xx:xx", and it's accepted. And then I have the info that is somehow encouraging:

       

      Capture du 2021-06-09 17-43-08.png

      And here is the failing connection. When I run "pair" it returns "successfull", and 5 seconds after it returns "connected: no"

      And it's the same thing when I try from the smartphone.

      pair fail.png

      The problem remains with v2019.1 and v2020.2

      Can somebody help me to find what is happening?

      Regards

      • Reply